Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000066Rosetta[All Projects] Bad Codingpublic2012-08-13 19:162012-08-21 19:40
Assigned Tompacella 
PlatformOSOS Version
Product Version 
Fixed in VersionAll 
Summary0000066: Incorrect documentation of dock_pert option in docking documentation
DescriptionCurrent docs the following for dock_pert:
-dock_pert [T] [R] To create a starting strucutre from the input structure, randomly perturb the input structure using a gaussian for translation and rotation with standard deviations [T] and [R]. Recommended usage is "-dock_pert 3 8"

But this is reversed from reality. It's actually -dock_pert [R] [T]. Such that dock_pert 3 8 gives a 3 degree rotation and an 8 A translation.

This seems different from rosetta2... Has this bug been sneakily here all along!?
Tagsdocking, documentation
Application(s) Affecteddocking
Command Line Usedall
Developer Options
Fixed in SVN VersionN/A
Attached Files

- Relationships
related to 0000065resolvedLabonte PyRosetta Incorrect documentation of RigidBodyPerturbMover in PyRosetta Docking Workshop (# 7) 

-  Notes
mpacella (Attentive Developer)
2012-08-17 13:40

There is actually no mistake in the docking documentation (although there was a mistake in the PyRosetta workbook documentation). Although the order of the parameters is R then T in the RigidBodyPerturbMover definition, when the options are read in from the command line the correct order is T then R. If you look at line 61 in you will notice that the variables "trans" and "rot" are assigned values of 1 and 2 respectively. When the options are read in a vector of magnitudes is created from the command line. Finally, while calling RigidBodyPerturbMover on line 239, the "rot" element (or 2nd command line argument) comes first followed by the "trans" element. So everything is in order and we have not been running docking improperly for the past 2 years!
jecorn (Developer)
2012-08-21 17:21
edited on: 2012-08-21 17:22

I recommend refactoring the docking movers to make this a bit more transparent.

Why assign the variables "rot" and "trans" to Sizes outside the protocols::docking namespace, and then use these shortcuts to populate a 2-member vector from the dock_pert option vector? Why not just assign separate Sizes for each perturbation parameter? Working from an arbitrarily ordered vector seems dangerously hard to read.

The tracer output is just as misleading, since it reverses the order of rot and trans when parroting the option back to the user (DockingInitialPert line 236)
"-dock_pert 3 8"is written back out as "option[ docking::dock_pert ]()8 3"

- Issue History
Date Modified Username Field Change
2012-08-13 19:16 jecorn New Issue
2012-08-14 16:38 smlewis Project PyRosetta => Rosetta
2012-08-16 15:02 Labonte Relationship added related to 0000065
2012-08-16 16:41 Labonte Tag Attached: docking
2012-08-16 16:41 Labonte Tag Attached: documentation
2012-08-17 13:40 mpacella Fixed in SVN Version => N/A
2012-08-17 13:40 mpacella Note Added: 0000063
2012-08-17 13:40 mpacella Status new => resolved
2012-08-17 13:40 mpacella Fixed in Version => All
2012-08-17 13:40 mpacella Resolution open => no change required
2012-08-17 13:40 mpacella Assigned To => mpacella
2012-08-21 17:21 jecorn Note Added: 0000078
2012-08-21 17:21 jecorn Status resolved => feedback
2012-08-21 17:21 jecorn Resolution no change required => reopened
2012-08-21 17:22 jecorn Note Edited: 0000078 View Revisions
2012-08-21 19:40 Labonte Category Documentation => Bad Coding

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker