Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000238Rosetta[All Projects] Crashpublic2013-04-02 11:392013-04-02 13:54
Reporterkimdn 
Assigned Tomomeara 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Product VersionTrunk 
Fixed in VersionTrunk 
Summary0000238: Incompatibility between new sp2+hackelec and cluster
Descriptionwith

-corrections:hbond_sp2_correction
-score:weights sp2_correction.wts

in option file (in an effort to use new sp2+hackelec potential), it crahses

"basic.io.database: Database file opened: scoring/score_functions/P_AA_pp/P_AA_pp
core.chemical.ResidueTypeSet: Finished initializing fa_standard residue type set. Created 6400 residue types
core.pack.task: Packer task: initialize from command line()
Segmentation fault"

without options

-corrections:hbond_sp2_correction
-score:weights sp2_correction.wts

in option file (in an effort not to use new sp2+hackelec potential), it doesn't crash
"basic.io.database: Database file opened: scoring/score_functions/rama/Rama_smooth_dyn.dat_ss_6.4
core.chemical.ResidueTypeSet: Finished initializing fa_standard residue type set. Created 6400 residue types
core.pack.task: Packer task: initialize from command line()
core.pack.dunbrack: Dunbrack library took 0.03 seconds to load from binary
protocols.cluster: RESCORING: S_00098130_from_1_1_0047.pdb
protocols.cluster: Adding struc: 2.122e-314"

I attach a flag file that I used.

(As a record,,,,,

3k pdb files -> seg fault
while 1k pdb files -> ran well)

TagsNo tags attached.
Application(s) Affectedcluster.default.linuxgccrelease
Command Line Usedcluster.default.linuxgccrelease @/nas02/home/k/i/kimdn/commands/flag_cluster
Developer Options
Fixed in SVN Version54637
Attached Files? file icon flag_cluster [^] (318 bytes) 2013-04-02 11:39 [Show Content]

- Relationships

-  Notes
(0000238)
momeara (Attentive Developer)
2013-04-02 12:13

Adding

-corrections:hbond_sp2_correction
-score:weights sp2_correction.wts

to the cluster integration test does not segfault. Doonam, can you please either add or link all the input files so that I can reproduce the segfault?
(0000239)
rmoretti (Attentive Developer)
2013-04-02 12:51

It looks like it's a issue with the Dunbrack library.

-corrections:hbond_sp2_correction turns on the dun10 library. If for some reason you had a corrupt dun10 library, that could account for the crash with the flag, but no crash without the flag (i.e. using dun02).

Make sure your database is up-to-date and matches the files on the server (i.e. svn status doesn't report any changed), and try deleting the generated dun10 binary (e.g. rosetta_database/rotamer/ExtendedOpt1-5/Dunbrack10.lib.bin), if any. (Keep a copy of the binary for later post analysis - we should give an error message if the binary is corrupt, rather than a segfault.)

The other thing is if you're running this on multiple processors/threads, you may be encountering write collisions with generating the dun10 binary for the first time. Try doing a single-processor single-threaded score with the -corrections:hbond_sp2_correction to pre-generate the binary prior to launching a multiprocessor/multithreaded cluster run.
(0000240)
kimdn (Developer)
2013-04-02 13:40

After reading rocco's note, I erased
"rosetta_database/rotamer/ExtendedOpt1-5/Dunbrack10.lib.bin"

and ran cluster again and this time it ran well like below.

Since 'Dunbrack10.lib.bin_led_seg_fault_compiled_at_54637' is too big, I copy the file into Kuhlman lab's internal site. (@ contador /home/kimdn/scr/data/do_not_erase/Dunbrack10.lib.bin_led_seg_fault_compiled_at_54637)

"core.pack.task: Packer task: initialize from command line()
Warning: Unable to locate database file rotamer/ExtendedOpt1-5/Dunbrack10.lib.bin
core.pack.dunbrack: Reading Dunbrack Libraries
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/cys.bbdep.rotamers.lib
...
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/asp.bbdep.rotamers.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/asp.bbdep.densities.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/asp.bbind.chi2.Definitions.lib
Creating tricubic splines for the backbone-dependent non-rotameric chi scores
Finished creating tricubic splines
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/glu.bbdep.rotamers.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/glu.bbdep.densities.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/glu.bbind.chi3.Definitions.lib
Creating tricubic splines for the backbone-dependent non-rotameric chi scores
Finished creating tricubic splines
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/phe.bbdep.rotamers.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/phe.bbdep.densities.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/phe.bbind.chi2.Definitions.lib
...
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/asn.bbdep.densities.lib
core.pack.dunbrack: Reading /nas02/home/k/i/kimdn/rosetta/rosetta_database/rotamer/ExtendedOpt1-5/asn.bbind.chi2.Definitions.lib
Creating tricubic splines for the backbone-dependent non-rotameric chi scores
Finished creating tricubic splines
...
core.pack.dunbrack: Dunbrack 2010 library took 35.51 seconds to load from ASCII
core.pack.dunbrack: Memory usage:
core.pack.dunbrack: CYS with 187664 bytes
...
core.pack.dunbrack: TYR with 5789104 bytes
core.pack.dunbrack: Total memory on Dunbrack Libraries: 93727608 bytes.
Warning: Unable to locate database file rotamer/ExtendedOpt1-5/Dunbrack10.lib.bin
Warning: Unable to locate database file rotamer/ExtendedOpt1-5/Dunbrack10.lib.bin
core.pack.dunbrack: Opening file /nas02/home/k/i/kimdn/rosetta/rosetta_database/dun10XtCuTa for output.
protocols.cluster: RESCORING: S_00000345_from_2_1_0001.pdb
protocols.cluster: Adding struc: 2.122e-314
core.pack.task: Packer task: initialize from command line()
protocols.cluster: RESCORING: S_00000345_from_2_1_0002.pdb"
(0000241)
kimdn (Developer)
2013-04-02 13:45

After reading rocco's note, I erased
"rosetta_database/rotamer/ExtendedOpt1-5/Dunbrack10.lib.bin"

and ran cluster again and this time it ran well.

Since 'Dunbrack10.lib.bin_led_seg_fault_compiled_at_54637' is too big, I copy the file into Kuhlman lab's internal site. (@ contador /home/kimdn/scr/data/do_not_erase/Dunbrack10.lib.bin_led_seg_fault_compiled_at_54637)

- Issue History
Date Modified Username Field Change
2013-04-02 11:39 kimdn New Issue
2013-04-02 11:39 kimdn File Added: flag_cluster
2013-04-02 12:11 momeara Assigned To => momeara
2013-04-02 12:11 momeara Status new => assigned
2013-04-02 12:13 momeara Note Added: 0000238
2013-04-02 12:51 rmoretti Note Added: 0000239
2013-04-02 13:40 kimdn Note Added: 0000240
2013-04-02 13:44 kimdn Description Updated View Revisions
2013-04-02 13:45 kimdn Fixed in SVN Version => 54637
2013-04-02 13:45 kimdn Note Added: 0000241
2013-04-02 13:45 kimdn Status assigned => closed
2013-04-02 13:45 kimdn Resolution open => fixed
2013-04-02 13:45 kimdn Fixed in Version => Trunk
2013-04-02 13:54 momeara Status closed => feedback
2013-04-02 13:54 momeara Resolution fixed => reopened


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker